Supported Browsers

Supported Browsers

This list refers to production versions of publicly released browsers that are compatible with Shelby State Bank’s Internet Banking system. You must meet the operating system and hardware requirements stated by the developers of each supported browser. Browsers are tested and qualified with Internet Banking, not the operating system or hardware platforms they run on. The versions listed below are the minimum required, but it is recommended that you update to the latest versions.

·         Internet Explorer, version 11

·         MS Edge

·         Chrome (current version)

·         Firefox (current version)

·         Safari, version 7.0+

·         Safari for iOS, version 7+